谁说中文不能编程了?快看文言文大战东北话

2020-02-10 09:57:51 0点赞 0收藏 0评论


自从有了互联网,每个月都会有编程小白发贴问,可不可以用中文编程。虽然老遭鄙视,但情有可原,非科班出身的程序员,理解编程就很难了,再加上一直头痛的英语,更是难上加难。后来支持中文的易语言受到了很多人追捧,就是出于这个原因。但主流程序员还是不屑一顾。

可从去年年底,事情发生了变化。一种叫文言文编程语言(wenyan-lang/wenyan)在github上大火,到目前为止有1万4个star. 一段文雅的文言文

吾有一數。曰三。名之曰「甲」。 為是「甲」遍。    吾有一言。曰「「問天地好在。」」。書之。 云云。

等效于下面的JavaScript

var n = 3;

for (var i = 0; i < n; i++) {

    console.log("問天地好在。"); 

}

同时还可以转换成Python和Ruby, 最重要的是图灵完备!但看了官方例程后,小编决定还是学好英语吧。

吾有一言。曰「「春日宴。」」。書之。 有數九。名之曰「數」。 恆為是。若「酒數」等於零者乃止也。    吾有三言。曰「「與君」」。曰「酒數」。        曰「「杯酒。可以窮歡宴。綠酒一杯歌一遍。」」。書之。 減「酒數」以一。昔之「酒數」者。今其是矣云云。 吾有一言。曰「「綠酒千杯腸已爛。」」。書之。

不能不说,用这个语言编程,很,但未免有点装。于是这两天,一门新的语言dongbei(github: zhanyong-wan/dongbei) 横空出世, 可以用东北话编程。它的Hello World是这样的

唠唠:“唉呀,这嘎哒真他妈那啥!”。

输出为

唉呀,这嘎哒真他妈那啥!

声明变量是这样的

老王装二

变量引用是这样的

老张是活雷锋。 

老王是活雷锋。 

老张装250。 

老王装老张加13。

完整的九九表是这样的

写九九表咋整:  # 定义套路 写九九表。

  老王从1到9磨叽:

    老张从老王到9磨叽:

      唠唠:老王、“*”、老张、“=”、老王乘老张。  # 打印 X*Y=Z

    磨叽完了。

    唠唠:“”。  # 空一行。

  磨叽完了。

整完了。  # 结束套路定义。

自从大年三十,春晚没把我逗笑,没想到看段代码把我快笑疯了。

翠花,上 re。  # 导入 python 的正则表达式 re 模块。

老王装“abd”。

寻思:整re.match(“a.*”,老王)?  # 调用 re.match()。

要行咧就唠唠:“OK!”。

要不行咧就唠唠:“砸了!”。

稍带着看了下源代码,居然只有一个Python文件,只有1200多行,除了sys,os外只用了re这个正则表达式库。看来是把中文翻译成python表达式了,代码简洁标准规范,据说作者是来自Google,真是集实力与搞笑担当于一身的奇才啊

虽然有了文雅至和接地气的两门中文语言,但还不能说中文编程语言的春天来了。毕竟世界上还有一大半程序员说的是英语,人类无法理解二进制,但起码能理解编程语言。而未来的编程语言应该是高效如C,易懂如Ruby,将开发速度与运行速度完美结合的语言。

当然了,现阶段最好的语言是PHP


未经授权,不得转载
展开 收起

Nintendo 任天堂 Switch《健身环大冒险》体感游戏套装

Nintendo 任天堂 Switch《健身环大冒险》体感游戏套装

339元起

《Plants vs. Zombies GOTY Edition(植物大战僵尸年度版)》 PC数字版游戏

《Plants vs. Zombies GOTY Edition(植物大战僵尸年度版)》 PC数字版游戏

暂无报价

《Squad(战术小队)》 PC数字版游戏

《Squad(战术小队)》 PC数字版游戏

134元起

Nintendo 任天堂 Switch NS 健身环大冒险 Ringfit

Nintendo 任天堂 Switch NS 健身环大冒险 Ringfit

799元起

烛龙 古剑奇谭三-数字标准版

烛龙 古剑奇谭三-数字标准版

72元起

Nintendo 任天堂 《新 超级马里奥兄弟U DX豪华版》游戏兑换卡

Nintendo 任天堂 《新 超级马里奥兄弟U DX豪华版》游戏兑换卡

299元起

HP 惠普 暗影精灵5代 台式主机(i5-9400F、8GB、256GB+1TB、GTX1650)

HP 惠普 暗影精灵5代 台式主机(i5-9400F、8GB、256GB+1TB、GTX1650)

4530元起

HP 惠普 暗影精灵5代 台式主机(i7-9700F、8GB、256GB+1TB、GTX1660Ti 6G)

HP 惠普 暗影精灵5代 台式主机(i7-9700F、8GB、256GB+1TB、GTX1660Ti 6G)

6331元起

索尼(SONY)【PS4国行游戏】地平线:零之曙光

索尼(SONY)【PS4国行游戏】地平线:零之曙光

79元起

索尼(SONY)【PS4国行游戏】最终幻想 15 Final Fantasy XV

索尼(SONY)【PS4国行游戏】最终幻想 15 Final Fantasy XV

249元起

Office 365 家庭版

Office 365 家庭版

249元起

微软 (Microsoft) Office 家庭学生版 2016 激活密钥 Mac专用 正版办公软件 一次购买 永久使用 非商业使用

微软 (Microsoft) Office 家庭学生版 2016 激活密钥 Mac专用 正版办公软件 一次购买 永久使用 非商业使用

749元起

Steam 《Chinese Parents(中国式家长)》 PC中文版游戏 国区礼物

Steam 《Chinese Parents(中国式家长)》 PC中文版游戏 国区礼物

24元起

Nintendo 任天堂 Switch NS 游戏主机 掌机 NS游戏卡带 游戏卡 不锁区 预购2月发煮糊了2 分手厨房 中文 年度合家欢游戏

Nintendo 任天堂 Switch NS 游戏主机 掌机 NS游戏卡带 游戏卡 不锁区 预购2月发煮糊了2 分手厨房 中文 年度合家欢游戏

322元起

UBISOFT 育碧 全境封锁2 Tom Clancy’s The Division 标准版 PC中文

UBISOFT 育碧 全境封锁2 Tom Clancy’s The Division 标准版 PC中文

78元起

《旺达与巨像》PS4实体版游戏

《旺达与巨像》PS4实体版游戏

163.5元起
0评论

发表评论请 登录
评论举报

请选择举报理由

相关文章推荐

更多精彩文章
更多精彩文章
最新文章 热门文章
0
扫一下,分享更方便,购买更轻松