来吧,一起搭建一台OPENWRT做系统的NAS

2021-05-11 11:22:25 62点赞 480收藏 25评论

[ 前言 ]

DIY的NAS系统已经运行约2年了,为同事和朋友提供稳定的影音媒体服务,所以在这里写下一个搭建教程,记录自己在用OPENWRT搭建NAS的过程中的步骤和心得。鉴于本人计算机知识有限,文中可能出现不足甚至错误的地方,希望大家斧正。

为什么选择OPENWRT作为NAS的系统?市面上有很多免费的NAS系统,如OMV、freenas、万由等等。这些系统作为专业的NAS系统,有着功能强大,界面精美等特点。可是基本都存在着系统需要独占一个硬盘,且安装复杂的缺点,经过多次的安装测试,所以我选在了OPENWRT。不敢说它是最好的系统,但是从使用情况来看,它是个人组建NAS系统最实用的系统,小巧、稳定而且高效。

好了,下面就随着我开始搭建你的基于OPENWRT系统的NAS吧。

[ 安装篇 ]

首先需要准备一台用于安装OPENWRT的台式电脑(以下直接称之为"NAS"),不需要多好的配置,只要它还能运行WIN7就行,然后再准备一个安装OPENWRT的U盘。其大小视用途而定,如果仅仅是用来搭建云盘,偶尔科学上网,那么一个2G的优盘就足矣。如果需要提供图片、视频等媒体服务或安装UBUNTU的虚拟主机,那就建议使用一个大点容量的U盘,比如64G或128G的优盘。

安装时,我们还将用到一个软件就是Win32DiskImager,最后是我们今天所用到的主角出场:KENZO大神编译的OPENWRT,下载地址 提取码:9jqy。

安装步骤:

1、打开Win32DiskImager,界面如下:

Win32DiskImagerWin32DiskImager

请在路径中找到OPENWRT的镜像文件,并再次确定盘符是否为需要安装的U盘。如无误,点击写入(write)按钮,静等写入完成。

安装的步骤到此就结束了,就这么简单,下面我们将进入相对复杂的配置阶段。

[网络配置篇 ]

将已经安装的U盘插入备用的台式电脑上,然后开机,并选择U盘启动。10~15秒后,我们将得到类似以下的界面:

OPENWRT界面OPENWRT界面

首先需要配置的网络,在上述界面中键入:vi /etc/config/network 并回车

此时屏幕显示

config interface 'loopback'

option ifname 'lo'

option proto 'static'

option ipaddr '127.0.0.1'

option netmask '255.0.0.0'

config globals 'globals'

config interface 'lan'

option ifname 'eth0'

option proto 'static'

option ipaddr '192.168.1.1'

option netmask '255.255.255.0'

option ip6assign '60'

option gateway '192.168.1.1'

option type 'bridge'

单击“I”,将光标移动至“option ipaddr '192.168.1.1'”处,将此处地址修改为你需要的地址:一般为192.168.1.X,1<X<254(请记住X的值)。修改完了,点击ESC键,并同时按下"Shift"+":"键,光标将自动屏幕最底部,键入wq系统将保存并退出编辑状态。

network编辑中network编辑中

输入“reboot",电脑将重新启动,至此将不再使用显示屏和键盘了。

将此电脑接入你的交换机路由器

另外拿一台笔记本,也接入路由器或交换机,打开浏览器,并在地址栏中输入:192.168.1.X,回车访问

OPENWRT登录界面OPENWRT登录界面

如果能看到上面的界面,就说明你的NAS系统已经开始工作了。

输入初始用户名:root,初始密码:admin后就进入了主界面

 主界面 主界面

点击左侧菜单中的”网络“-”接口“,添加DNS(这对下一步安装docker至关重要,建议使用119.29.29.29和114.114.114.114),并取消”桥接“。如需IPV6,单击”添加新接口“按钮,将新的接口名称命名为”WAN6“,新接口协议选择DHCPV6客户端。

IPV6IPV6


这里有个小提示,看看你接入wifi的手机是否获取了IPV6的地址,一般以24开头的。如果以f开头,那么就是你的宽带或路由器是不支持IPV6的。

点击“提交”后,屏幕上会出现WAN6的设置界面。首先在全局网络选项-IPv6前缀里面删掉系统默认的IPV6前缀,见下图。

删除IPV6前缀删除IPV6前缀

然后点击WAN6接口后的修改按钮,在高级选项中取消“使用内置的IPV6管理”,其它选项见下图。

IPV6高级选项IPV6高级选项

高级设置完成后,在物理设置中将桥接接口取消,然后保存,并在左侧菜单”系统“中选择”重新启动“。

电脑重新启动后,如没有设置错误,系统将获得IPV6公网地址。此时已经可以在外网用IPV6的方式访问这台电脑。

已经获取IPV6公网地址已经获取IPV6公网地址

对于DDNS与IPV6地址的绑定,这里就不再赘述。设置后的界面如下:

动态DNS动态DNS

我在DYNV6申请的域名,这里值得注意的是,DYNV6申请域名激活时必须科学上网,否则无法完成激活流程。

DDNS配置DDNS配置

网络配置完后,接下来就是磁盘空间的配置和挂载。

[磁盘空间的配置]

首先对U盘剩余空间进行配置和挂载。当前U盘空间可能仅仅使用了1个G,剩余的空间,我们将格式化成为另一个盘,用来作为DOCKER的安装空间。

这里要用到第2个常用工具:putty。通过SSH的方式连接NAS,然后输入fdisk /dev/sdb,键入P,此时终端会列出U盘当前的分区情况(如下图,我已经分好了,所以出现了3个分区,共计2G)

分区列表分区列表

如还有剩余空间,键入N,然后一路回车,生成新的分区。最后键入”W"将分区表写入磁盘并退出。

接着要作的就是格式化分区,mkfs.ext4 /dev/sdb3(3可替换你的实际盘号)。

最后进行挂载,菜单见“系统”-“挂载点”,如下图。

分区挂载分区挂载

硬盘空间的处理方式基本同上,只是设备名由U盘的SDB变更为SDA。这里就不再作更多的叙述。

磁盘空间挂载完毕,就应该安装相应的软件并提供系统服务了。

[服务篇]

1、影音媒体服务jellyfin,使用putty连接NAS后,直接复制以下命令,进行无脑安装

docker run -d -p 8096:8096 -v /jellyfin/config:/config -v /mnt/sda1/media:/media jellyfin/jellyfin

2、云盘服务 FILEBROWSER,无脑安装命令

docker run -d -v /mnt/sda1:/srv -v /opt/filebrowser/filebrowserconfig.json:/etc/config.json -v /opt/filebrowser/database.db:/etc/database.db -p 8899:80 --name filebrowser filebrowser/filebrowser

8096和8899为服务端口。

[ 内网穿透篇 ]

内网穿透主要针对无IPV4公网地址。需要的材料为公网IP云主机、FRP服务器端软件、FRP客户端软件。

下载地址

我的云主机使用的是WINDOWS SERVER2008,因此我下载的是frp_0.36.2_windows_amd64.zip ,压缩包里包含了服务器端和客户端软件。

服务器端配置

[common]

bind_addr = 0.0.0.0

#与客户端 绑定端口

bind_port = 7000

#dashboard 用户名

dashboard_user = user1111

#dashboard 密码

dashboard_pwd = user1111

#dashboard 端口,启动成功后可通过浏览器访问如http://ip:7500

dashboard_port = 7500

#设置穿透端口

vhost_http_port=3999

#设置客户端token,对应客户端有页需要配置

token = 479328479286

完成服务器端配置后,使用命令 frps.exe -c frps.ini 启动服务(注意路径)。云主机还应该注意在防火墙中开放以上用到的端口,如7000,7500,3999等。

客户端配置:

config frp 'common'

option log_max_days '3'

option login_fail_exit '0'

option enable_cpool '0'

option time '40'

option vhost_https_port '443'

option log_level 'info'

option enable_http_proxy '0'

option protocol 'tcp'

option token '479328479286'

option server_port '7000'

option vhost_http_port '3999'

option tcp_mux '1'

option server_addr '云主机公网IP地址'

option enabled '1'

NAS中添加客户端配置后,即可透过http://云主机公网IP:3999访问。


总结

好了,到此,如何基于OPENWRT的NAS系统的流程就基本讲完了。通过以上步骤,这个简单小巧的NAS系统已经可以为自己和朋友们提供基本的服务,如影音媒体服务,私有云盘服务以及FTP、科学上网、PT下载等。

搭建一个NAS系统就是如此简单,要的是多看多尝试。


如果你觉得本文对你有所帮助,欢迎,点赞、收藏、评论!有点碎银子就更好了!

谢谢大家的阅读,我们下次再见!



展开 收起

群晖(Synology)DS418play双核心4盘位NAS

群晖(Synology)DS418play双核心4盘位NAS

3850元起

HIKVISION 海康威视 Mage20双盘位 NAS网络存储服务器 无盘版

HIKVISION 海康威视 Mage20双盘位 NAS网络存储服务器 无盘版

984元起

Lenovo 联想 个人云存储T2 双盘位NAS存储(RTD1296、2GB)

Lenovo 联想 个人云存储T2 双盘位NAS存储(RTD1296、2GB)

999元起

QNAP威联通TS551 2G内存5盘位双千兆4K转码网络存储服务器NAS

QNAP威联通TS551 2G内存5盘位双千兆4K转码网络存储服务器NAS

3999元起

群晖(Synology)DS218play四核心2盘位NAS

群晖(Synology)DS218play四核心2盘位NAS

1980元起

威联通(QNAP) TS-212P3 2盘位NAS网络存储器 四核心处理器 TS-212P3 TS-212P3(空机)

威联通(QNAP) TS-212P3 2盘位NAS网络存储器 四核心处理器 TS-212P3 TS-212P3(空机)

869元起

ZSpace 极空间 Z2 2盘位NAS (RTD1296、2GB)

ZSpace 极空间 Z2 2盘位NAS (RTD1296、2GB)

1184元起

QNAP 威联通 TS-873A 八盘位 NAS存储 Ryzen V1500B 8GB

QNAP 威联通 TS-873A 八盘位 NAS存储 Ryzen V1500B 8GB

暂无报价

QNAP 威联通 TS-473A 四盘位 NAS存储 V1500B 8GB

QNAP 威联通 TS-473A 四盘位 NAS存储 V1500B 8GB

暂无报价

QNAP 威联通 TS-673A 六盘位 NAS存储 V1500B 8GB

QNAP 威联通 TS-673A 六盘位 NAS存储 V1500B 8GB

暂无报价

华硕 ThunderboltEX 3 PCI-E转雷电3 主板扩展卡

华硕 ThunderboltEX 3 PCI-E转雷电3 主板扩展卡

699元起

QNAP 威联通 TS-453Bmini 4盘位NAS(J3455、4GB)

QNAP 威联通 TS-453Bmini 4盘位NAS(J3455、4GB)

1899元起

Synology 群晖 DS918+ 4盘位NAS(J3455、4GB)

Synology 群晖 DS918+ 4盘位NAS(J3455、4GB)

4680元起

Synology 群晖 DS218+ 2盘位NAS (RTD1296、2GB)

Synology 群晖 DS218+ 2盘位NAS (RTD1296、2GB)

4906.56元起

Synology 群晖 DS218play 2盘位NAS (RTD1296、1GB)

Synology 群晖 DS218play 2盘位NAS (RTD1296、1GB)

1900元起

QNAP 威联通 TS-551 5盘位NAS(J3355、2GB)

QNAP 威联通 TS-551 5盘位NAS(J3355、2GB)

1539元起
25评论

发表评论请 登录
  • 最新
  • 最热
评论举报

请选择举报理由

相关好价推荐
查看更多好价

相关文章推荐

更多精彩文章
更多精彩文章

冬哥CD

Ta还没有介绍自己

发文累计被1225人收藏

关注 打赏
作者其他文章
最新文章 热门文章
480
扫一下,分享更方便,购买更轻松