MikroTik RouterOS 记录 篇三:RouterOS ddns & OpenWRT IPv6 Wireguard 远程组网

2023-07-09 15:51:43 13点赞 85收藏 16评论

小伙伴们关于新玩具 MikroTik RB750gr3 新分享,终于有时间交作业了。

RouterOS ddns & OpenWRT IPv6 Wireguard 远程组网

MikroTik RB750gr3

看过我文章的小伙伴们,可能知道我之前的方案。

单位和家都部署的是OpenWRT 软路由,然后通过 Wireguard 组网。不过单位是一个单网口小主机加上网管(二层)交换机搞的。

用还是能用的,我这不是爱折腾么,看好多大佬们都用 RouterOS,个人只用虚拟机体验过,不过没买许可证,有限制。考虑到干瘪的钱包就在海鲜市场上入了这个,成色还可以 200块到手如果选择 MikroTik RB750gr2 这种老版本的话,七八十块一个性价比更是拉满了。

Mikrotik千兆有线路由器RB750Gr3(hEX)ROS宽带软路由家用稳定RB750r2百兆384元京东去购买

MikroTik RB9005

MikroTikRB5009UG+S+IN万兆智能网管型路由器1530元京东去购买

可玩性和性能拉满的必须推荐 RB9005了,分两款: 普通和poe升级款。

poe升级款 cpu主频高点儿,其它没什么区别,这款主要是 arm 处理器,能跑容器,可玩性更高些。

ddns 设置 ipv6 公网

想要玩这个,需要买个域名。我的域名选择的是 dnspod 腾讯,所以脚本方面我用的dnspod示例。至于ipv6设置我在上一篇文章里面已经分享过了。

ddns 脚本设置

登陆以后 web管理界面

RouterOS ddns & OpenWRT IPv6 Wireguard 远程组网

RouterOS ddns & OpenWRT IPv6 Wireguard 远程组网

RouterOS ddns & OpenWRT IPv6 Wireguard 远程组网

RouterOS ddns & OpenWRT IPv6 Wireguard 远程组网

脚本

网上找了好多都用不了,我这里自己改了下。

#pppoe interface

:local pppoe "bridge" #这里更换为你的桥接接口

#dnspod api token

:local token "id,api_token"

:local domain "你的主域名"

:local subdomains {"二级域名"}

:local ipadd [/ipv6 address get [/ipv6 address find interface=$pppoe global ] address ]

:put "this is ipv6 address with netmask $ipadd"

:set ipadd [:pick $ipadd 0 [:find $ipadd "/"]]

:put "this no mask $ipadd"

#print ipv6 address

:local dname

:local record

:local recordid

:local recordip

:foreach i in=$subdomains do={

:set record [/tool fetch url="https://dnsapi.cn/Record.List" http-data="login_token=$token&format=json&domain=$domain&sub_domain=$i&record_type=AAAA" as-value output=user]

:set record ($record->"data")

:set record [:pick $record [:find $record ""records":"] [:len $record]]

:set recordid [:pick $record ([:find $record ""id":""]+6) [:find $record "","ttl"]]

:set recordip [:pick $record ([:find $record ""value":""]+9) [:find $record "","en"]]

:if ($recordip!=$ipadd) do={

:set record [/tool fetch url="https://dnsapi.cn/Record.Ddns" http-data="login_token=$token&format=json&domain=$domain&sub_domain=$i&record_id=$recordid&record_line_id=0&value=$ipadd" as-value output=user]

:log info ("[$i.$domain]update ip as:$ipadd")

} else={

:log info ("[$i.$domain]no need update IP")

}

}

计划任务设置

RouterOS ddns & OpenWRT IPv6 Wireguard 远程组网

RouterOS ddns & OpenWRT IPv6 Wireguard 远程组网

参照图片设置,其实命令设置的话也很方便,这里就不上了。

Wireguard 设置

RouterOS ddns & OpenWRT IPv6 Wireguard 远程组网

RouterOS ddns & OpenWRT IPv6 Wireguard 远程组网

这里私钥生成有点问题,我用openwrt生成的。

添加对等节点!

RouterOS ddns & OpenWRT IPv6 Wireguard 远程组网

RouterOS ddns & OpenWRT IPv6 Wireguard 远程组网

Wireguard 接口设置

RouterOS ddns & OpenWRT IPv6 Wireguard 远程组网

RouterOS ddns & OpenWRT IPv6 Wireguard 远程组网

ip设置

RouterOS ddns & OpenWRT IPv6 Wireguard 远程组网

OpenWRT 设置

RouterOS ddns & OpenWRT IPv6 Wireguard 远程组网

这里添加 RouterOS 的节点,就可以测试连接了。

组网完毕

速度测试

10.0.5.0/24 内网机器做 server 测试,我这是一个 100M的宽带,上传应该只有 20-30M!

RouterOS ddns & OpenWRT IPv6 Wireguard 远程组网

这次用 对等节点 OpenWRT 作为服务器

RouterOS ddns & OpenWRT IPv6 Wireguard 远程组网

这只是其中一次测试,多测试几次,看上去能跑满带宽!

感谢阅读

RouterOS ddns & OpenWRT IPv6 Wireguard 远程组网

欢迎点赞、关注、评论!

欢迎加入圈子

下期预告

大家对什么感兴趣呢? 欢迎来圈子或者留言讨论!

既然玩路由,打算写个关于网络的!

作者声明本文无利益相关,欢迎值友理性交流,和谐讨论~

展开 收起

三佳迅dtmb地面波数字电视天线机顶盒免费看高清电视信号接收器农村室内外家用无需网络卫视无线接受收台 质尊版升级电视天线(仅数字电视用) 连接线7米

三佳迅dtmb地面波数字电视天线机顶盒免费看高清电视信号接收器农村室内外家用无需网络卫视无线接受收台 质尊版升级电视天线(仅数字电视用) 连接线7米

暂无报价

SDDTMB 地面波DTMB数字电视天线高清机顶盒室内外通用电视信号免费无线农村新老式电视接受器天线 全国通用室外八木电视天线长10米+1米2条=11米

SDDTMB 地面波DTMB数字电视天线高清机顶盒室内外通用电视信号免费无线农村新老式电视接受器天线 全国通用室外八木电视天线长10米+1米2条=11米

暂无报价

新华三 H3C iMC-智能管理平台标准版-200 License

新华三 H3C iMC-智能管理平台标准版-200 License

暂无报价

山泽(SAMZHE)SFP28+线 DAC线缆堆叠线万兆直连线25G兼容华为/华三/思科/H3C曙光浪潮中兴等3米DAC-25G-03

山泽(SAMZHE)SFP28+线 DAC线缆堆叠线万兆直连线25G兼容华为/华三/思科/H3C曙光浪潮中兴等3米DAC-25G-03

299元起

博扬 QSFP56-200G-SR4多模光模块 多模MPO接口 200G光纤模块 850nm 100m BY-QSFP56-200G-SR4 200G MPO多模双纤(100m)

博扬 QSFP56-200G-SR4多模光模块 多模MPO接口 200G光纤模块 850nm 100m BY-QSFP56-200G-SR4 200G MPO多模双纤(100m)

2599元起

大唐卫士DT-ZY8007 一体化机柜机房带空调UPS 消防门禁模块化通道可

大唐卫士DT-ZY8007 一体化机柜机房带空调UPS 消防门禁模块化通道可

80000元起

奥恺(AIENKIS)AK-SRS-100 皮线热缩管 皮线光纤热熔管 双钢针蝶形光缆尾纤保护管热熔套管/100根

奥恺(AIENKIS)AK-SRS-100 皮线热缩管 皮线光纤热熔管 双钢针蝶形光缆尾纤保护管热熔套管/100根

15元起

丰应子 授时校时北斗双模GPS时间同步PTP时钟NTP服务器6网口 恒温晶振 FYZ-DWX156 NTP服务器恒温晶振款【6网口】

丰应子 授时校时北斗双模GPS时间同步PTP时钟NTP服务器6网口 恒温晶振 FYZ-DWX156 NTP服务器恒温晶振款【6网口】

11999元起

海奈 语音电话100对110型 电信工程级镀金版语音电话配线架 HN-TJ100

海奈 语音电话100对110型 电信工程级镀金版语音电话配线架 HN-TJ100

149元起

新华三 H3C iMC-EIA终端智能接入组件-500 License

新华三 H3C iMC-EIA终端智能接入组件-500 License

暂无报价

新华三 H3C iMC-EIA终端智能接入组件

新华三 H3C iMC-EIA终端智能接入组件

暂无报价

光网在线(GW-FIBER)万兆SFP+DAC高速电缆华为华三威联通qnap广泛兼容 0.5米 SFP-10G-CU0.5M 堆叠线 兼容华为 华三 因特尔Intel通用

光网在线(GW-FIBER)万兆SFP+DAC高速电缆华为华三威联通qnap广泛兼容 0.5米 SFP-10G-CU0.5M 堆叠线 兼容华为 华三 因特尔Intel通用

69.99元起

山泽(SAMZHE)QSFP28线 DAC线缆堆叠线万兆直连线100G兼容华为/华三/思科/H3C曙光浪潮中兴等1米DAC-100G-01

山泽(SAMZHE)QSFP28线 DAC线缆堆叠线万兆直连线100G兼容华为/华三/思科/H3C曙光浪潮中兴等1米DAC-100G-01

429元起

新华三H3C iMC-智能管理平台标准版-25 License

新华三H3C iMC-智能管理平台标准版-25 License

暂无报价

新华三 H3C QSFP-40G-LR4L-WDM1300 QSFP+ 40G 光模块(1310nm,2km,LR4L,LC)

新华三 H3C QSFP-40G-LR4L-WDM1300 QSFP+ 40G 光模块(1310nm,2km,LR4L,LC)

暂无报价

山泽(SAMZHE)SFP+线DAC线缆堆叠线 万兆直连线 SFP-10G兼容华为/华三/思科/H3C曙光浪潮中兴等1米DAC-10G-01

山泽(SAMZHE)SFP+线DAC线缆堆叠线 万兆直连线 SFP-10G兼容华为/华三/思科/H3C曙光浪潮中兴等1米DAC-10G-01

99元起
16评论

  • 精彩
  • 最新
提示信息

取消
确认
评论举报

相关好价推荐
查看更多好价

相关文章推荐

更多精彩文章
更多精彩文章
相关好价
最新文章 热门文章
85
扫一下,分享更方便,购买更轻松